Xbox one S E101 Error

Bought an Xbox one s with no display to fix. replaced the retimer chip and it worked fine - booted well but very slow. Decided the HDD might be on the way out and took it out to test and found bad sectors.
Replaced the HDD and tried an OSU but each time it barely hits 1% and gives me an error code e101 00000504 8b050041
I have tried other drives and caddies and also tried re downloading the OSU1 file all with no joy - each time I try and OSU it gives the error - Any ideas please?

Have you tried replacing the cable from the motherboard to the hard drive?

Hi Thanks for taking the time to answer

Yes I have tried 3 different hard drives - (aside from the original which failed the seatools long test) and 3 different cables still get the same result.

Does the disc drive work?

HI Again

Yes the drive spins up - and all the drives I tried on my pc tested as fully functional using the seatools test software)

do you check if this console is in insider program?

Hi miguel

Thanks for answering - Im not sure how that would affect the ability to do an OSU as I know very little about the insider program. Can you explain please?

E101 means you are trying to update an older version than the one that’s already on the console - Try re-downloading the OSU files and putting them on the flash drive and try it again. I have a One X at the moment with the same issue, but the OSU on Microsoft page isn’t working so I’m waiting for it to be updated.

If the console is in the insider program it cannot normally be updated with an OSU - I’ve never actually come across this issue though after 60+ repairs so I’m sure you’ll be fine.

HI

Thanks for your reply. I did re-download the OSU from microsoft and that made no difference.

Is there a way of checking if the console is in the insider program and if so how can I then I update it please?

im thinking that the console is indeed in the insider program as when i look at the os version it is listed as 19041.4333.amd64fre.vb_release_xbox_dev_2010.21007-0000

the dev in the release makes me think so - but how can I now do an OSU because that looks like a very old dev file (2010) anyone any ideas?

Update

I downloaded the latest OSU file today and it finally managed an offline update - xbox is finally fully working…

Thanks for looking

I’m having the same issue with the same version. Any OSU, hard drive or cable will give me E101 Error code upon second stage of install. (Within 2% of verify stage). I’m guessing its also an insider. Repaired hundreds of units, first time came across this issue. Have not found a workaround as of yet. Anyone have any luck?

I finally managed to fix mine by downloading the latest osu file - I just kept trying new files until one worked.
Im thinking you need to get an osu that is later than the version that is on the machine