Xbox One X disc drive not working

I have an Xbox One X and back in May I upgraded the internal 1TB hard drive to a Samsung 1TB SSD and since then my optical drive will randomly not be detected. It’ll take the game in just fine and sounds normal while reading it but it acts like there’s no disc drive hooked up. And if I use the Blu Ray app it will give me an error saying no disc drive detected.

I’ve reset the console a few times and it will work right after resetting but after it shuts down it won’t work. I’ve also done an offline update a couple of times and took the SSD out and wiped and reformatted it like originally done and the same thing. It worked on the first bootup but then wasn’t detected after it shut down. I’ve switched from instant on and energy saving modes and the only thing that I found that works without resetting is unplugging for a minute after a full shutdown and then booting it back up. I’ve had it for a couple of years now and I’m not sure if it’s a coincidence after swapping the SSD in or if I need a new disc drive/motherboard.


Did you try cleaning the laser lens?

I didn’t do that because the inside of my Xbox had almost zero dust in it. And if I shut it down, and unplug the power for a few seconds then boot it back it will work, without taking the disc out at all. And if I don’t quit the game and just turn off the console it will work when booted up. But if I shut it down or reboot it, then it’ll work. It’s been working for the last couple of weeks playing the same game but then I restarted it, and it didn’t read the disc. Shut it down, unplugged it and booted it back up and has been worked just fine.

I’ve figured out that it only has the problem with disc drive not reading if there’s an external drive that’s formatted for games plugged in. I put the original hard drive back in and it worked fine as well. I used the new 9.0 script for HDD master and had the same result.

1 Like

I’ve never heard of this before. That’s a strange one.

I replaced the swapped the disc drive and cables out too to eliminate that as a problem but it didn’t make a difference. If I restart it then it won’t read the disc unless I do force shutdown or unplug it and plug it back in. Switching between instant on and energy saving modes also didn’t make a difference. If I just turn it off and don’t do a full shutdown or reboot it will work fine until whenever I restart it.