BCM4356 - Switch working except no wifi/bluetooth

I am stuck with an issue regarding WiFi/BT IC. When I got the switch (HAC-001) it’s motherboard had a short on the 3.3 V rail which turned out (after injecting voltage) to be located under/in the BT4356. I replaced it with a new one from a seller that claims it is a working chip for Switch.

The switch itself is now fully working except it doesn’t see any networks and joycons aren’t connecting wirelessly. However it still shows a MAC address, as if it could communicate with the IC.

I believe it could be a fault in some of the other chips surrounding the IC. Did anybody have a similar problem? Is there anything specific I should focus on?

Thank you very much. :slight_smile:

1 Like

My switch lite have same problem, I suspect its power supply chip is damaged.Because I test the Wifi IC on anther motherboard,it is works good.

Will check that area, thank you very much. I reflowed the BCM again and this time I have wifi, but no bluetooth. I will also try to check the antenna before relowing it one more time.

Also, I am missing one of the filtering (I assume) caps under the BCM IC. Does anybody know the value please? I can’t embed pictures yet, but it’s one of the two 0201 caps that are next to the bigger ones. They connect between the non-ground leg of the bigger one and ground.

At least now I can confirm that the IC doesn’t have to be preprogrammed with Switch specific firmware (the seller told me in PM that he just uses standard factory made chips without additional changes). :slight_smile:

Reflowed two times, still no bluetooth. Wifi is working nicely though. :slight_smile:

Does please anybody have any tips on what to diagnose next (except replacing the IC itself)? There seems to be a bunch of BT only lines (clock signal, enable, data, i2s, etc.). Do some of them go through resistors?

Thank you! :slight_smile:

you know what I’ve had a switch with no WiFi. I swapped it out and I lost Bluetooth but got WiFi.

then I did it again and both worked fine.

I have got alot better now at doing these and I can tell if the installation went well.

imo you have to use a used chips pulled from switch. I could be wrong on this as I haven’t used a new one. so for me sticking a already faulty chip on is possible.
(I don’t check which version) all seem to work.

as for the missing components, I’ve no idea sorry. but if your chip is shorted it will show up on the surrounding caps alot of the time.

Thank you. I replaced the chip again, just to be sure - got the same result (working wifi, bluetooth not working). I will try to solder the missing cap back and see if it helps before any further reflows.

By the way, it’s this one:

Anybody knows the value please?

chip looks the right placement. but I can’t see the other side to be sure.

I’ll try and find the vaule when I’m next on repairs of switch, but I don’t know when that will be.

more than likely it’s just your cap missing then

Thank you so much. I will wait patiently :slight_smile: Don’t want to just assume it’s the same as the neighbouring cap on the other side.

That’s a 0.1uF cap, my guess voltage should be less than 6.3v

1 Like

Thank you so much! I will solder a new one and see if it helps with the missing bluetooth connection.

UPDATE: I soldered the missing cap - still no change. Everything works except the bluetooth. Does anybody have any idea what can be causing this? Thank you :slight_smile:

So… I traced all the connections that have anything to do with BT from BCM to their destination in order to see where they generally go. The board itself has some missing components elsewhere, so I think a missing component in this circuit is the culprit.

However then I realised the scans of the board are of a different revision (mine is probably a much later one). In any case I am attaching the traced image for posterity… maybe it will help somebody someday. :slight_smile:

In any case - if somebody has a newer revision of the original switch, could you please take a look at this portion of the board and check if these places are not populated?

Thank you very much. :slight_smile:

1 Like

SHORT answer, no one there

1 Like

Thank you so much! This is awesome. :slight_smile: Do you please have the same shot of the back side? There are few unpopulated areas as well.

To be honest I think somebody used that board as a donor at some point (it was already missing few other parts that I repopulated).

NVM,here is my back side shot

1 Like

Thank you so much. My board doesn’t seem to have any component missing, though bluetooth is still not working.

Interestingly enough the BT communication seems to be partially working. If there’s no nearby BT device ready to connect then I get the “No BT devices found” message right away. If there’s a bt device nearby it actually searches for a while. Hard to guess what could be the potential problem (except the fact that it’s not the BT_REG_ON signal).
Any idea what should I probe or check? This is kinda killing me :smiley:

Are you using BCM4356 wifi chip on the V2 marico board/HAD-CPU-XX ?

Yes… is this revision using a different wifi chip?

AFSIK, wifi chip becomes CYW4356 from v1 HAC-CPU-20(most), v2 and lite. I personally never tried BCM on CYW or other way around, but I’ve seen vid before saying brand new chip most case doesn’t work on switch directly due to lack of burn-in fw IMO. SO I stick with donor chip from other switch board and keep CYW on CYW on-board device

Thank you. I heard it was a myth. Plus CYW / BCM was just a rebrand.

But in any case, if it was true would the wifi work? I have no problem with it… only the stubborn bluetooth is still broken. :confused: