CC2 shorting to GND


Switch wasn’t turning on or charging. Tried known good battery and switch starts up. Capacitor above usb-c port had short.

M92, P13 and BQ capacitors showed no shorts.

Removed USB port and short from capacitor has gone. Can see two pins B3 and B4 have burned out which I can fit a small trace to copper contacts.

Problem I have is CC2 (B5) is shorting to GND. Same if I check pin 37 on M92p36.

Any ideas what may be causing it or where to search for fault?

Sorry I can’t upload images, I’m assuming due to first post

Thank you for your help

Mainboard is HAD-CPU-01


CC1 is showing as 0.514v in diode mode.
CC2 is showing as 0.006v

Is this the result of a faulty diode on the CC2 circuit? Or another component?

Thanks again for any help

no sure if that was solder joint or what. it seems you have this cc pad solder to the edge of board(gnd) with little solder

Thank you for your reply. I checked the pad again and moved solder away from edge but it is still shorting to GND.

Do you have any other ideas?

Thank you

Please check on the backside if a esd diode is on the cc lines.
If so, remove it. If the short is still there, the m92t36 is bad and needs to be replaced

Doe to your burnt B3 and B4 I would check also the continuity throught the choke (TX1-) = B3

Thank you for your help.

The TX1 choke has continuity.

There is no Esd diode on this model of mainboard.

Thanks again

I removed M92T36 and the short disappeared from B3/CC2.

Replaced with a new M92 and short didn’t return so that problem is solved.

Added small jumper wires for missing usbc pins and installed new usbc port.

Plugged in known good battery and switch starts up but doesn’t recognise charger being plugged in. It’s drawing 0.00 amps.

BQ24193 capacitors aren’t shorting. Could the chip still be the issue? Is my usb post install bad and is there a way of checking it without removing?

Thanks for your help so far.

use type-c breakout board to test

On M92t36 CC1/pin35 im getting 0.4v
On CC2/pin37 it’s 0.004v

I get 5.14v on the test point directly above the usbc port.

Can’t find a breakout board in the uk. Will be a while until I can get one.

Tested pins on BQ24193 and nothing is shorting other than the 2 correct GND pins.

Is there any other fuses I could check or a certain route I can follow the voltage to see where it stops reaching M92T36?

Thanks again, I feel im close to solving this!

What s about this cap? Did you checked it after fixing the m92t36?

Yes, it’s not shorting any more. It’s showing 5.17v on one side

Did you test both sides of the usb c plug?

Yea, rotated both ways and exact same 0 amps

Sorry, I have just seen you added image of caps around m92.

I have checked those caps and some are much higher. I also have bad connection on some of M92t36 pins. I will reflow them and retest in diode mode.

Thank you for your help

Ok, I have good news!

Reflowed pins of M92T36 and it’s now charging at 0.41a. Battery was approx 2.4v so will take a while to charge and I think it will fast charge at a later point once can boot up.

I’ve noticed two strange things before I reflowed the M92T36:

The readings of these by the BQ24193 was much higher than what these diagrams are showing.

Also 1 off the capacitors by M92T36 wasnt reading anything.

Despite this it seems to be working. Do I need to worry about these 2 problems?

Thanks so much for your help. Feels so good to get it charging (and it’s charging both ways with the USB port)

I would reflow the m92t36 again and check if every pin makes a good contact with the pad.
At the side of this ic over the pins are contacts, so you can check if contact and pad have the same value to be sure the m92t36 is propper soldered.

Would typically indicate a bridged pin/pad on this IC or surrounding components, was this IC reworked?

I’d resolve before connecting power

I hadn’t reworked the BQ IC and it didn’t look like it had been by anyone else.

I’ll take a closer look around the BQ area for bridges etc.

I already applied power before seeing your message. It’s charging at 1.41amps with the usbc plugged in either rotation. Booting fine and all seems to be working in handheld mode.

I’m not getting a signal to the tv when in the dock which I wasn’t expecting seeing as both charging orientations work. I’m going to recheck the P13USB as I’ve read a few other posts of Calvins where a reflow worked on the IC and possibly the chokes.

I’ll update you with further info. If you’ve any other ideas or likely causes let me know and I’ll check them.

Thanks for all your help