Crash after first boot logo

Hey everyone. Has anyone had any luck with this issue outside of swapping M92 and BQ?

I have a old board I bought broken that I finally got around to checking out. It did not boot at all at first but I noticed the fuel gauge was a bit chipped and beat up so I replaced it. That got the system to turn on but it crashes after the first Nintendo logo.
No sound, touch, etc.

I know the LCD and battery is good as it’s my test frame and it still works with other boards. I swapped the fuel guage, M92 and BQ. I know the eMMC is good as I tested it on another V1. Not corrupted (though maybe a software issue?). The LCD connector is in perfect shape.

I may swap the MAX77620 PMIC but, frankly, have no reason to suspect it. Same for the backlight IC as everything in both areas test fine. Same for the IC near the LCD connector.

Anyone know what may (even hypothetically) cause a crash after first boot, especially is the fuel guage WAS definitively bad? Thanks for any insights as I’m stumped and about to just start experimenting. Worst case, I figure I’ll transplant the SoC and eMMC to another board if nothing else works so if you have any educated guess I haven’t considered I’d love to hear it.


I may be wrong, but I don’t think you can swap the emmc to another switch motherboard and have it just work unless you have the keys. I believe it’s married to that specific motherboard. It very well could be the emmc, but I’m unsure of a way to test it since you can’t try it out on another motherboard. Anyone correct me if I’m wrong.

Yeah, you cant swap them out, and doing so may cause a fuse mismatch.

Hi, when the WiFi IC is Bad, it can cause a no Boot or bootloop too.

Maybe Check there or give it a reflow.
The solder balls in the switch havent a good quality and sometimes they break.

1 Like

Hey and thanks for the reply.
I didn’t swapping the emmc board to another Switch, I meant swapping the SoC and Emmc to another board (as I’m sure they’re fine and I have the equipmeng and tools to do so).

Thank you for the reply! I’ll actually try that next and before the other ICs. It’s a bigger clue than I have atm and I have a few good wifi ICs lating around. I’ll reflow first and then just replace it to be sure.

Like I said in the OP, this has broken down to a learning board for me. I have general experience but with this exact fault it seems like there are 3 chips to replace or bust. Even the wiki says to change M92, check battery and and LCD. If all are good “there is no known fix”.

So this is as much a learning thing and general community help project. Worst case is I transplant the SoC and eMMC and call it a bad board after swapping out just about everything I can think of.

Thanks and I’ll report back results.

Swping both CPU and NAND would work, but Best it’s the same Board number, V1 and V2 have some Different Mainboards.

Could also be a RAM problem.

1 Like

Exactly. I’d swap to the same board revision as this is a V1. So I’d love to get it working on it’s original board but will transplant if I have to. Thanks!

Ok, quick update. Swapping the WiFi and MAX77620 did not help. Next I think I’m going to do the RAM chips and then probably the backlight IC. After all swaps I’m still in a crash after first logo.

More soon.

Sorry it won’t let me edit on mobile but it’s still a no-go after swapoing just about everything but RAM. The seemingly mysterious GC ASIC must hold system specific software/encryption as changing it made it so I don’t even get the first logo, just screen on for 2 seconds and then off.

So I’m gonna throw the old one back on and then swap RAM. If that doesn’t do it I’m down to hunting random regulators/components…which may just prompt me to abandon the board and transplant the SoC/eMMC to another just to be 110% sure all is good there.

If it’s not the RAM and (educatedly assumed/tested) not the SoC/eMMC, it means that some tiny, random component can not short entirely but give a 1 logo crash. Update soon.

Wow thats insane. What about the other two Max ICs? (on is the small fuel gauge, not sure if you already replaced that) and another small Max IC is South of the CPU on the B side.

All I think off if not the RAM is the CPU.
I mean even if it’s not Shorted, there Could be some other Problem

1 Like

Yeah, fuel guage was the first replacement as it was the only chip to show anything looking loke damage. The board originally did nothing with draws that pointed to the PMICs.
Fuel guage was a little chipped (you know how those MAX ICs are basically glass) so I swapped it and that got it to boot to the first logo and then crash. So, an improvement. I then swapped M92, no change. BQ, no change. Battery and LCD is 100% good so I made this post as I’ve never had a “first logo & crash” board fixed with what I had already done so - almost out of boredom and wanting to find info to help the community - I decided to swap everythinf I could.

So far I’ve done all of the above, all MAX ICs, the GC ASIC, the IC above the sound chip, PI3USB, the backlight IC and the IC near the LCD connector. I also removed all non-essential parts that Nintendo did themselves on other boards.

Still first logo and crash. I’m doing RAM next, likely tonight or tomorrow. My issue being that I have tons of Samsung RAM but this board has SKHynix. I don’t think it should be an issue if I change both but I’m not sure if the system uses “RAM Learning” at first boot to lock itself into a RAM type as Hynix has a different resistance than Samsung (at least in all RAM I’ve dealt with in GPUs and other devices).

So we will see! I’ll report when done. If that fails, I’ll probably double check all readings on the random voltage refulators/mosfets and just start swapping those, too. It’s about 18 total to my count. If that fails, it’s just going to be a case of transplanting the SoC/eMMC as the issue would have to be in the PCB itself. Rare but I have seen it a few times

Update soon.

1 Like

Yeah after All the work or even before there Could be some damaged trace insife the board.

Have you already checked for the present voltages if you turn it on? Maybe you See missing voltage and can relate which rail is faulty

1 Like

It does matter I’m afraid, fused to the manufacturer, so it it’s Hynix, you have to stick with Hynix etc :frowning:

That all being said, It’s unlikely to be Ram related in the first place I’m afraid.

1 Like

I am remembering someone with no boot issue had Bad caps left of the CPU

1 Like

Well dang. I suspected that may be the case but wasn’t sure if Nintendo set that or not. I knew they couldn’t be mixed and matched but wasn’t sure if they are set at manufacture to be one or the other and only that.
So I’ll scratch that plan until I get some good Hynix modules (I’m pretty sure all I have is Samsung atm).

As a test/discovery board in my eyes, I think I will wait until then despite RAM not being high on my list of suspects as well. I agree that it’s highly unlikely but why not try at this point and in this scenario? Kinda just wanna swap to rule out another possibility/variable.

I appreciate the reply as you’re clearly very knowledgable about Switch! Appreciate it, along with all other replies. I’ll update if I eventually swap RAM or find anything else interesting.

Yeah, all appear to be present. That’s the weird thing about it. Everything tests fine in that regard.

As for those caps, I’ll check that out as well. I appreciate the replies, too! Truly. Anyone that offers any help is appreciated and especially in a scenario like this where my motive is more about helping everyone more than myself.
I’ve always heard that these “one logo crash” scenarios described as a case of being about 3 or 4 things before getting a big “I dunno”, hehe.

More than trying to get this board up and going, I wanted to hopefully add another bit of potential things to look for when others in the future have this issue.
So any and all advice and thoughts are appreciated. I’ll report back if/when I find anything as I need to wait until I have some Hynix RAM to do that swap. As Severence said, it’s unlikely the RAM but I think we both assumed that as is. His confirmation is definitely helpful so at this point I’m in a “let’s just do it to do it” mindset :slight_smile:
I’m good at reball and install so worst case is nothing changes. One less thing to wonder about.

Thanks to you both again and I’ll report back as soon as I have something to add!

1 Like

I guess it could still be a software issue? Is it a patched board?


@Dwhdwh did you tried booting into hekate with TegraRCM? Maybe you can reflash the firmware

1 Like


It’s an unpatched board. It could be software as the only thing I can go on is read errors. It shows as ok when mounted on anorher V1 Switch but that only shows so much. I even tossed it on an actual eMMC breakout reader and all sectors show as good/accessible but that still doesn’t rule out a bad write. It’s something I view as definitely possible but not likely based on what I’m able to see.


Yeah, I tried and it won’t let me due to the system not staying on. This is what lead me to swap the MAX ICs to begin with as I thought it could just be a power issue. It gets to RCM and I’m jjst fast enough to send the payload before it turns off due to that slight delay in boot>RCM.