M92T36 pin 6 no input

Hi! Thank you for reading.

I have a switch has a ripped off soldering pad on backlight connecter.
I tried to repair but I made a bridge between pin 1 and 2. (and I turned the power on.)

and I found a capacitor was fallen off near the M92T36. (it’s replaced now)


I don’t know whether those events are related however, my switch became to pull only 0.45a. and M92T36 has 0 volt on its pin6.

I replaced ENxx IC (the IC under the Sound IC) but it didn’t help.
Where should I look at for further investigation?

Thank you in advance.

Well, pin 1 is ground, and 2 doesn’t look to be the high voltage line, it heads over to the backlight IC on the other side of the board.

@Insomniac Thank you. That may not be the cause.

However, I found out that M92T36 pin 18 (which is connected to ENxx enable pin if I’m right) has only 0.7 volt or 1.5 volt.

It changes by plugging in the USB cable. Should I replace M92T36?

I’ve investigated the board and I found missing capacitors under P13USB.
I could search the capacitance and I have the same valued capacitors.

Then I got constant 0.7v on the resistor next to ENxx (which is connected to enable pin of ENxx)

I look through the whole PCB and I found another missing part under the Game cartridge reader connector. As I see on the google it’s a resistor but there’s no info about the value.

Is the resistor related to the issue?

No idea. But that resistor is connected to the APU and the video chip, so could easily prevent boot. On a board with no APU attached I get a reading of 4.7k (it reads 4k with the APU attached).

@Insomniac Thank you for the value.
I soldered 4.7k resistor but ENxx still gets 0.7v enable pin input.
(and the voltage on the resistor was the same, I assume they share the same power source)
So, I assume M92 get the voltage from its 18 and give it to ENxx Enable pin somehow.
What I want to know is where the voltage comes from.
I tried all test point near power circuit but I couldn’t find. (All I found are the points near the capacitor is connected to pin 18)

Which is the enable pin on ENXX?


D4 pin in the picture

0.7V does not consititue a logical high afair, but rather 1.8V.

I’d check your other rails are coming up following prompting the console to boot at the inductors surrounding the main PMIC, if your not getting them then you won’t get your 3V3PDR

If your not getting them thern following connecting a USB cable it points to M92/USB issues or issues with their surrounding components. I’d also try promting the console to boot with the power button and bttery connected and checking those rails once again.

To anyone else, the image posed above (by me) is wrong and is not a proper identification of the chip and was my error, though the pinout is almost the same.- the chip is RP602Z330C-

Thank you for your comment.
So, I need to check 1V8PDR. Do you have any recommendations for where to start to check?

I would suggest measuring resistance to ground on the coils around the pmic.

As mentioned, checking the voltages following prompting the console to boot (try USB and failing that the power button with battery connected) at the main max PMIC on the surrounding inductors, if your not getting the voltages (incl your 1V8PDR) then most likely an M92/USB related issue.

As Insomniac mentioned you can also measure the resistance to ground on the inductors surrounding the PMIC which is good as a matter of course, which will let you know if something is dragging down any of your priimary rails, though at this stage I don’t think that’s your issue.

@Insomniac @Severence
Thank you for advice. I’ll check what you mentioned.
I’d like discuss with you when I find something.

@Insomniac @Severence
I’m still measuring components around the PMIC and I haven’t found any strange values for now.
However, I get 1.8v and 3.3v (Eventually) at rare probability.
They are gone with unplugging USB-C cable.
Do you have any idea about the symptoms?

Sorry I don’t really know what this means, I guess you saying they are present but intermittent?

If the battery is connected they should remain, if your finding they aren’t then I would be looking at checking your battery, battery connector etc

If you were saying the rails were intemittent above then these battery related issues (and a dodgy USB connection) would likely also be the cause

Sorry for my bad English.

I mean I get 1.8v at random probability when I plug in USB-C cable.
otherwise I get 0.7v on 1.8v rail.

I measured voltage drop around two MAX ICs. I found out that some points are different from @Calvin 's map.

But, I don’t know what this means.

Any advice will be appreciated.

If the battery is connected, following prompting the console to boot the rail in question should be 1.8V constant, if it’s random, then it indicates either dodgy USB port and/or dodgy battery connectpr

I’d verify the USB with a breakout board and ensure all lines have continuity to the destination/s

Red probe on ground for Calvins charts.

Though I would advise you measure the resistance to ground on the surrounding inductors instead.

I measured those values with the red probe on ground.

however, here’s the resistance of the inductors

Two inductors are located above the max77620a shows resistances over 1k, are they normal?

if they’re I’d like to replace the USB port.

and I found another capacitor is missing on the EMMC module.