My PS5 won't turn on

I have a PS5 that I got from my nephew which was dropped, thinking it would work again. The I/O Port was the only thing that I saw that was physically damaged, I bought one and replaced it but it won’t turn on at all. I’m new to this and don’t know what to do from this point.
Any suggestions is greatly appreciated!


What happens if you press the start button?

  • nothing
  • one beep no light
  • three beeps no light
  • one beep 2 sec blue light

What is the I/O port? (USB/LAN/HDMI)

Nothing happens no lights no beep. The I/O port is where the power on button and eject button on the face of the PS5, It has a USB port on the face as well

Do you have a multimeter and some experience with it?

I wonder NO BEEP happened even before OP replace any I/O port,since console was dropped.

Yes I have some experience with and I do have a multimeter.

No Beep before the I/O port was replaced.

I would open the PS5 and check if 12V are delivered at the psu pins on the mainboard.

How do I locate the PSU pins?

red +
blk -
they should show 12V

I tested the psu and I get no reading from the psu.

It is possible that a short on the 12V at the mainboard is forcing the psu in safe mode. So I would take the psu out and check the psu direct for 12V or the terminals on the mainboard for a short.

If the psu is still not putting out 12V, you have found the cause for the defect.
If you are not an electrician, I would recommend to buy a replacement psu.

Ok. I will take it out and test it. If it is a short on the mainboard causing issues what’s the fix for that?
I’d rather buy a replacement psu instead of trying to fix it.

If the short is on the mainboard and the psu alone test fine, the task would be to find the shorting element at the 12V line on the mainboard.

Thanks! I will do the psu test later today. Hopefully the motherboard is not damaged because of the drop.
I was thinking possibly it could or can be repaired.
Appreciate all your help so far.

I took out the PSU and I get no reading. I tried another power cord still nothing.

I bought a power supply I get the blue light power on one beep but nothing on the screen.

blue light stays on or just goes off after beep?

When I turn it on I get one beep and blue light. When I press the power and hold at first press one beep and when second beep sounds it shuts off.

I’m getting nothing on screen.

Does blue light stays on?

That’s normally goes to recovery/maintain mode with white light stays on. I believe you just don’t have it