Nintendo Switch 0 amps and no display

Hi there, I recently got a nintendo switch that couldn’t power on and showed 0 amps being drawned when attached to 5v charger . I replaced the M92T36 and P13USB, and the problem was still there. I tried to use a known good battery and the switch did power on but I could only see the backlight(so no video output), the touchescreen and the audio worked just fine (I tried to touch it 3-4 times and made the unlocking sound). I tried another screen that I had but still no video and only the backlight.
I don’t know if these 2 problems are related. I noticed that the usb c port was changed but when I check with the multimeter the voltage nearby the port (like where is the fuse) it gives me 5 volts(with and without battery). What can i do? Thanks

are you getting any shorts on the m92 or p13 caps?

Hi, no shorts, i forgot to mention that one of the hdmi filter under the p13 was missing and i replaced that too

I think the problem with the charging it s related to the bq24, but is weird when i plug in charging cable and battery the multimeter shows shorts in the caps near the chip, when i leave it without voltage shorts are gone, is that normal???
for the video output i still have no clues

If You can hear a unlocking sound and nothing is shown on the display, my first guess is that there is a problem with the backlight. It also means that the Switch is booting completly.

0 amps is in my eyes a problem on the line to the M92T36. If the M92T36 is powered by the USB, it should consume at least something around 0.08 amps. Maybe a short or the fuse in this line.

I would check this first:


I checked with charger and battery and in the orange rectangle in the photo (510) multimeter shows 5 volts

Quick Update: I noticed that 1 cap behind the m92 wasn’t making a good connection and then i solder it. Now when i plug in the 5v charger with the battery it gives me around 8-20 mA drawn for 2 or 3 seconds and then it goes 0 A again

The original charger delivers something around 15 V. So if it plugged You should meassure 15 V at the marked points.

Yes, indeed. I measure it with the 5 volt charger just for convenience (since I have an usb tester that shows me the volts and amps drawned) I just tried even with the nintendo charger and i get 15 volts in the same points

It’s still me, I made another account because it wouldn’t let me write another comment.
Btw actually now for that strange reason with the 5v i get around 0.20-0.36 amps drawn
constantly and cpu became a little hot… it’s better than before but still there s something wrong

As you have mentioned, usb port has been changed, I would check each pin diode value to make sure previous repair leaves no rabbit whole, especially 2nd lines of the pin may not have proper diode value/good contact from different tech.

So You have two problems:

  • no charging
  • nothing on the screen but backlight is on

Can You measure the displayed voltages on Your board?

Did the dock gives a hdmi signal from the switch to a tv?

jkyoho :thank you I’m definitely gonna to check that later on today since sometimes ampere drop to 0.06, sometimes it goes 0 and when i remove and reinsert the cable it goes again to 0.20-0.36
Calvin : I tried to put in in a dock and sadly my tv didn’t recognise hdmi output so i assume i doesn’t work in dock mode, but when i connect to the dock the backlight turns on but i can’t say if it’s charging or not. I measured the voltages with the 5v charging cable connected: red is 4.2(battery is almost fully charged) , green is 2.4 v and orange 4.4 v

Here’s what i got on each pin:
1 ok
2 3 ok
4 0.473
5 0.477
6 0.447
7 no connection( i get 0L)
8 0.690
9 0.474
10 11 ok
12 ok
unfortunately i cannot measure the pins on the back

A6 (D+) and A7 (D-) are for USB 2 communication.
I would check the USB connector if pin A7 is loose. If it s ok, check the upper blue marked filter for continuity.

I double checked all the pins of the usb c connector and they make good contact.
The filter is making continuity

Do You have contiunity between the top of the filter and the pads 2 and 3?
Please also make a cross check from 2 to the right and 3 to the left, to be sure taht the esd protection isn t making problems.

Yes, continuity ok and 2 goes only on left and 3 only on right

That s not a good sign.
If You can t find the problem below the filter, the cause of this problem could only be under the soc.

I have another usb c port for the switch laying around, I ll try to solder that.
Maybe it has to be something with the pin number 7 of the photo that @jkyoho sent me since I don’t get any diode value from ground and the pin is not loose