Nintendo switch black screen after damp with programmer

Good evening.
I am a new member, so I take this to greet the staff and all of you.
I would like to offer you a question.
I am a professional repairman.
I replaced the display with a nintendo switch, usually I dump with a programmer, sometimes with known programs.
this time to me, after reading with the programmer, I reinsert the emmc schrdina, and the nintendo does not turn on.
in rcm it starts, but does not accept the fusee-primary atmosfere.
I think something is corrupt at the fw level.
but I don’t know how to rebuild it.
I state.
I have:
BOOT0, BOOT1, RAW.bin and all prodinfo partition, profinfof, etc.
I checked with NxNandManager and Hack disck all the keys and all confirmed. I get with NxNandManager vers FW 11.01 sn and more.
some program or guide would be needed to allow the reconstruction of the sysnand.
Thank you in advance for your attention, I apologize for the language, I write from Italy with translator


I dont think the display is “married” with the tegra chip? does backlight turn on? can you access hekate? could you restore with Hekate if you have boot0/1 and all the raw.bin ? To rebuild the nand you need hekate or tegraexplorer (Check below link)?

Good morning
Thanks for your interest.
i can access in rcm and with hakate.
launching the cwf goes into block.
the swicth is locked at fw levels.
the fw is 10.2.0
i have the same problem as in this link
( [Per favore, aiutami a ricostruire Switch Nand]))
I created the key txt as suggested by KiloooNL
I obviously have the update fw 11.0.0 and 11.0.1
but I can’t start ChoiDujour.exe
I have performed the various procedures but I always get an error, while paying attention to all the guide explanations.
i think if i could downgrade or upgrade the OFW, i fix the problem.
I humbly ask you if you can teach me how to proceed to run ChoiDujour.exe
Thank you in advance.

Thanks again, I look forward to your advice on how to start ChoiDujour.exe I have tried them all I do not understand where I am wrong.
The link in the post above i put only the object, the links can not be inserted
:pray: :pray: :pray: :pray: :pray: :pray: :pray:


I have attached pictures. Start cmd on the folder and use the command below

“EmmcHaccGen --keys prod.keys --fw fw”

My downgrade/upgrade firmware is in the “fw” folder. prod.keys is generated by lockpick.rcm and placed in the EmmcHaccGen folder

first of all thank you.
I’ll try your two directions.
I update the post in the meantime.
I have downgrated to the following versions, 8.10, 10.2.0.
same problem.
I took the console upgrade to version 11.0.0 and 11.0.1
same problem. proceed with ChoiDujour and other programs, the keys on hacdmount are ok.
I think there is something that escapes me, I have 14 blown fuses, but with the fw 11.0.1 it had to start.
I can’t figure it out.
I also carry out your tests and update you.
thank you

@FXDX I’m sorry but I don’t see private messages with your nick name.
forgive me I’m new
could you please check if sent?

I have no messages in me private message box. Write me here what you want and if I can help you with something

fuses do not matter if you booting through Hekate

I was able to downgrade and upgrade, with your suggestions.
but unfortunately the switch still doesn’t work.
starting the console in normal conditions the screen is always dark.
if I start in RCM hekate starts, it allows you to launch any payload, but if I launch atmospheres, the logo appears, and then gets stuck with a black screen.

but if I launch atmospheres with hakate, lanch, the logo appears, and

emummc is forced but not enabled?
failed to launch hos!
press any key…

When you mean logo. Is it atmosphere logo or nintendo logo ?

Maybe you have problems with the M92T36 chipset.

I mean atmospheres logo and immediately after it appears

emummc is forced but not enabled?
failed to launch hos!
press any key …

the nintendo logo never appears …
Note: if you start in normal mode, the screen is dark

Definitely a nand problem. Have you tried fxdx link ?

not what the fxdx link is

I am also convinced that it is something corrupt in the nand, being read.
the strange thing is that the keys, with HacDiskMount, are ok.

I’m not convinced this is a FW issue… sounds more like a hardware issue to me

the nintendo, before I read the nand with the programmer, was fully functional …
after reading the nand and reassembling it on the console, this happened.
I believe in a corruption problem fw, because I think that when it was read some data was corrupted

But what caused the corruption?

You mention in the title something about “damp”, do you mean the EMMC or the board (or both) got liquid on them?

When you say “programmer” do you mean you were using EMMC to SD adapter on the PC?

If you want, you can PM me your boot0, boot1 and prodinfo and prodinfof and Biskeys I’ll generate the FW for you iin both choi and EmmcHaccGen… just to rule FW out as the issue.