No Backlight, No Image, Missing 1.35v MAX77620

Hello, got a switch lite with no shorts i can find so far. When prompting to boot by connecting usb cable i get the below voltages from M92T36, MAX 77620 and MAX 77812.

M92T36 voltages
5 - 3.3v
6 - 3.3v
18 - 1.8v
21 - 20v
22- 15v
25 - 0.15v
26 - 0.15v
27 - 0v
28 - 0v
36 - 1.5v
38 - 1.49v
39 - 2.8v
40 - 1.5v

I can take resistance/diode values of M92T36 if needed.

values shown in RED means Red probe on ground and values in BLACK is Black probe on ground.

is the 1.35v for the RAM?

Don’t think so, pretty sure Ram is just 1V1 and 1V8.

Missing 1V35 seems to be quite common on Mariko and Lites for some reason, I had one case with a Mariko rev where I was missing 1V35 and it was a resistor near the SoC with a damaged end-cap causing it to be open only when powered. I had another case where it was a Lite board also missing this rail, in this case it was due to board warp and there was likely an open line below SoC or Via damage - Lite assemblies are really poorly designed with a section of the board only being supported by plastic which promotes this.

Dunno if those pics are from your board but if not, might be a good idea to post some pics front and back of the board and also checking to see if you have any board warp

1 Like

Hi, Severence thanks for your input. the pics are from ifixit, also the board doesnt have any warp.

forgot to mention tha the board had some water damage.
just had a look at my phone and these are the pics i took of the water damage before cleaning with IPA.

I uploaded the rest of the pics here of the board once i cleaned with IPA


replace # with .

(in FireFox i think you have to right click and view image for Hi Res images)

Hmm the trouble here is I’m not as familiar with Mariko/Lites and don’t really know the mechanism for missing 1V35 for sure, so I don’t know if this rail won’t be present without (or with a bad) CPU/GPU buck IC for example or with a bad BQ IC for example :thinking:

I guess this is just a black screen and no boot logos? and typical 0.4A current draw?

Hi, i have a lite board with the same issue. The only thing missing is the 1.35v output of the main pmic all other rails are present.
Unfortunately I don’t have at the moment a good board to make comparisons but i noticed a short on the upper side of the NFC chip around 2 ohms. Can you please check on your board if you have the same reading? I don’t know if this is normal…

I removed the 2.2k resistor, the two pads are shorted.

Seems normal, I measure approx 1.3 ohms with the resistor in place on two known good boards.

I also should have mentioned above, it might jjust be on Mariko/Lites that this rail doesn’t get enabled until later on in the boot process and any number of other things may have to be initialized/detected prior

Same question to you @Equalize


As it might be this rail not being present is a red herring and the symptoms should be treated as any other regular Switch rev with the other more common symptoms

4.1v battery shows 0.05-0.06A sometimes 0.07A
3.8v battery 0.47A

and yes on the black screen and no boot logos.

So if this was a regular Switch board rev and we take the 1V35 rail issue out the equation I would be looking first at swapping the fuel gauge, then the CPU/GPU buck, then BQ (though it rarely causes these symptoms) if still nothing then there is a chance it’s EMMC related and an issue reading/writing, on Lites you’d have to connect up an adapter to the relevant lines to check this on PC

do you have a diagram of the relevant lines to connect to? and by adapter do you mean mmcblkNX or Low Voltage e-MMC Adapter?

i’ll try fuel gauge and BQ, I don’t have the CPU/GPU buck i’ll need to order some.

Sorry I don’t as I haven’t yet documented it, I would guess the SX Lite modchip is connecting to the bare minimum EMMC hookups, and I reckon you should be able identify which is which by measuring resistance to ground and comparing to a regular rev Switch EMMC module

Alternative way is to pull the IC off the board and buzz it out to the TP’s or pull the IC reball and install it on a standard Switch rev module PCB

I’d use this one :slight_smile:



switch is working now.

before replacing the Fuel Gauge i checked resistance to GND and PIN A1 (AIN) was low (reading in kohms instead of Mohms) then i decided to boil flux and IPA under the chip and that worked.

fuel gauge low resistence
fuel gauge

after powering on got to the home screen the after about 3 seconds it crashed with error code 2153-0321.

found out that after googling that error code is related to sound. I looked around the ALC chip and saw a track going to pin 2 had corroded, run a jumper and that worked.


so thanks a lot Severence

Thats great news man, glad you got it fixed up :smiley:

Also good to know that these sorts of faults can trigger the missing 1V35 rail on Maiko/Lite boards

Hey @note9 did you poke your probe under the chip (17050) to see how much it was reading? Because that’s a 10K Ohm resistor above it and that cap has nothing to show, at least on my board. So I don’t really get why did you circle those in red or how they’re related to the MOhm reading. Could you please explain?

Hi, sorry haven’t visited the forum for a while.

no i probed between the cap and resistor or the test pad on top since that track is going to pin 1

Thank you for your response. Yes, I get over 1M Ohms but that “05” diode is beeping on both ways, no matter which side I have each probes on. I’ve got two spare boards, tried them and it seems to be behaving the same way. Is that even normal?

You will get ground on both sides of the large current sense resistor (05)