Switch doesn't play JoyCon Connection animation

Hi all!

I just picked up a Switch. It clearly at some point got liquid in the right joycon rail, as it was seriously corroded. I have tried to clean that one up, but for the sake of making sure everything was working replaced it with a new one (Brand new part).
With this installed, the Joycon itself is detected, it shows as both charging and connected to console, but it does not play the connected animation / sound.

I have done my googling, and knows causes seem to be:

  1. Firmware lower that 9.1.0 - It was already on 9.1.0, but have now updated it to 12.0.0, with no change.
  2. Dirt on pins - It’s a new rail, and have tried with different right joycons. Gave it a quick clean anyway - no difference.

I also connected a new rail from a joycon to it, so I could test for continuity all the way through, and I seemed to get a connection to somewhere from all pads on the joycon side to the connector in the switch. I also checked for loose pins at the switch connector.

As far as I can tell, everything looks fine. Does anyone know if there is anything else I should try? I have ordered another set of rails, just in case the one I have is bad. Is there a specific pin that is required for the snap animation?

Thanks in advance!

I have the same issue on a Switch beside its 2101-0001 error:

Thanks for the info Calvin! Hmmm, I am guessing you never found a solution for it?
It seems weird that it is only the animation that is missing and that all other functionality is fine!

There were some good hints in that thread about checking readings so I will start there and let you know if I spot anything!

No, I didn t find a solution. The abnormal was the always high signal from the soc to enable 5V charge line to the right JoyCon rail. Normaly it is switched on after JoyCon detection. I also had a short on the rail due to light corrosion on the contacts.

At my Switch with the JoyCon issue the 2101-0001 error is the bigger problem, so I didn t test further on the JoyCon issue… :stuck_out_tongue_winking_eye:

Given that this switch had corrosion in side the rail contacts itself, it does somewhat sound like it is caused by a short or partial short between pins. That said, given that it is entirely cosmetic, I may just consider this one “good enough” and not worry about it too much - If I start swapping random parts around I am bound to just break it fully…
I did just open it up to look at the area on the back of the board, but couldn’t find any differences in the behaviour of the L and R side diode, though I couldn’t get it to behave like I diode on either side either.

there is a certain pin on the connector which if open would cause the symptoms your seeing.

I posted in a topic with Calvin on a similar subject where I provided a photo a continuity “map”

I’ve had cases where over rework by prior “techs” caused board swell and the vias fail, as such certain lines going to the joy con connecter are open, see if you can find that topic by searching for “continuity map” in the switch category and check that you have continuity at the areas in the photo, if not run a jumper.