Switch freezes after Nintendo Logo and crashes EVEN WITH LINUX

Hi there,

glad to have found this forum and hoping to get some help here! I already posted my issues on GBAtemp (post [Switch bricked – tried lots of stuff – nothing helps – still fixable?]) however I think this forum is a better fit!

I don’t want to give up fixing my Switch!

So I am going to describe my issue as clear as possible.

It charges, shows battery charging symbol. When powering it on normally, Nintendo Logo appears, then screen goes black and nothing happens. If I want to restart it, I have to press Powerbutton for 10-15 seconds.

What works still?
–> entering RCM, injecting payloads (havent found one that didn’t work so far)
–> creating/restoring NAND backup of eMMC, eMMC benchmark works well
–> creating emuMMC, flashing Linux or Android with hekate
–> USB tools for mounting rawnand and SD
–> joycons work when attached in hekate
–> wifi

What does not work?
–> booting up anyting

What have I tried?
–> booting normally: black screen after Nintendo Logo (seems frozen)
–> booting emuMMC/sysNAND/cfw sysNAND (atmosphere): black screen after Nintendo Logo / after atmosphere Logo
–> booting Linux(switchroot ubuntu): initial setup works, then freezes after setup completes
–> booting Android (after successful flashing with TWRP): screen remains blank, fan is running, nothing happens (TWRP boots up successfully if pressing VOL+)
–> dumping original firmware and found it’s 10.0.4, burnt fuses count = 13
–> downgrading using various tutorials using ChoiDujour, HacDiskMount and EmmcHaccGen and, almost all of them were completed successfully but I still get the black screen after Nintendo Logo
----> funny thing with this tutorial (suchmememanyskill github) was, that in TegraExplorer when running the systemRestore.te script it would just show two red 00 that freezes when trying to restore the system folder, and after waiting a few minutes the screen turns funny with grey background and some purple stripes that are expanding by a few pixels slowly ^^… When mounting System partition in HacDiskMount and modifying it, theres no error message though.
–> restoring the NAND backup that I took after I got the console various times and starting again from the beginning…

Some hardware facts:
–> battery charges only with 0.4A only!
–> if the battery is drained, after the nintendo logo, I get the charging screen with the little battery symbol on the top left corner, but this screen freezes as well and I have to hard reboot
–> I found a shorted capacitor, it is the bigger one located south of the m92t36
but the capacitor itself is not shorted. (I’d post an image but as new member I’m not allowed yet)

–> I replaced the M92T36 chip successfully and assume there was no damage to the original, as there is no change in behaviour after the replacement

After reading through a few topics here, my next guess would be the max17050 fuel gauge. but I thought before I just wildly order parts and risk damaging it further, I’d ask you guys here and see if we can work it out =)

So yea, thanks for reading and any help is very welcome! :innocent:

Cheers!!

Hi,

After replacing M92 IC it cleared the short right?

No, it didnt unfortunately.

Can you post the pic of the shorted cap now? and also the resistance to ground.

No, can’t post images yet, just tried it. is there another way of showing it here? I will measure the resistance tomorrow.

imageshack(dot)com

xhttps://ibb.co/1d2sQjP

Something on 1V8PDR …this will be fun :wink:

Just checking, but you were measuring with the battery/power disconnected right?

Sorry, what is 1V8PDR ? :no_mouth:

yep, I took the cap off and measured it and its not shorted but back on the board its shorted again, battery/power is not connected.

1.8V (Primary Derived Rail) is where you short is.

Given the graphical glitches in TegraExplorer, my suspicion would be one of three things, Ram, SoC, or the two Max IC’s below and to the left of the SoC. Unfortunately all these things are a bit of a pain to conclusively test and tbh it could literally be anything on this rail at fault (which is near everything)

First try disconnecting you EMMC module and see if the short on that cap clears, if not, then check you haven’t got any bent pins inside your USB as a physical fault here could in theory put a subsequent fault on your 1V8PDR.

Failing that, I’ll have to draw up a few points for you to measure tomorrow

1 Like

Alrighty, I got my little workstation setup and ready to run some tests! SO, firsty I wanna mention that I am not at all a professional elictrician, and I am pretty much learning by doing, but I will do my best!

So I disconnected the emmc and the short is still there.

I measured both points with my multimeter set to 200R , and it fluctuates wildly (!) between 10R and over 200R. never stands still, keeps going up and down constantly.

I hope I can post images soon… it would be so much easier.

Before going further, switch your meter over to the 20K position and let me know your reading on that cap

OK,

having it set to 20K, it still fluctuates between 0.01 and 0.07, sometimes hold on 0.03 and if I hold it longer (which is really not easy with my shaky hands ^^) it stays at 0.01. I get the same results for both points, resistance to ground.

Ok, was just checking this wasn’t a meter issue.

Remove the board, flip over, measure resistance relative to ground at the points highlighted in the image. Note this is a Lite board but the points remain the same.

btw, was this a gradual fault or instantaneous? was there anything that happened which could have triggered it, for example a drop, liquid, bad USB etc?

OK will do.

I got the switch as it is and dont know what happened to it before. I figured somone had already tampered with it, as the CPU cover had been removed and put back on. Also, after a while the touch stopped working and it looks like someone also had tried stuff with that small board that connects the digitizer to the mainboard. A resistor there is missing. Thats all I know about the possible things that happened. It didn’t seem to have liquid damage. possibly something got fried while someone tried to fix / hack it… :thinking:

Hmm never a good sign.

tbh I’m surprised it’s still booting to hekate with a full 1V8 short.

Loading biskeydump payload shows a match, smiley face right?

When your able to post pics i’ll give the board a once over

lets try this now

Yay =)))

not sure what you mean? I was fully able to retrieve keys with lockpick

btw this is the board after I replaced the chip. it was my 1st chip replacement and I blew away few parts but was able to put them back in place, poorly but it works :joy:

Okeydokey, my meter (set to 2k) reads:

purple–> .358
yellow–> .068
red–> .007

blue–> fluctuating wildly ^^

Can i suggest removing this IC for the time being, i notice some of the joints don’t look good (no offence i appreciate this is your first time) so would just like to take it out of the equation for now.

If you can take a few snaps of the rest of the board, particularly of the areas you suspect somebody else has messed with.

try using the Biskeydump payload, it’s a bit clearer in terms of showing you if your SoC and EMMC is a match, would be a bit pointless continuing with physical repairs if the EMMC is not a match :smiley: (for example, if somebody swapped it)