Charging but no display or dock image no shorts

Here’s the ones listed in the datasheet example circuit

https://www.mouser.co.uk/ProductDetail/ROHM-Semiconductor/RSX101VA-30TR?qs=4kLU8WoGk0tB41wg4aRbGQ==

I’d verify the size of the diode package with some calipers though first just to be sure.

Provided the specifications are a close match, will be fine as a replacement, though I don’t imagine either of these rails draw anywhere near 1A max, you could probably go lower if you wanted worst case

yeah saw that but down as not recommended anymore and not in stock, the alternative that is recommended is RSX101VAM30 but that is slightly larger than the one I found and the shipping costs are too much compared to the part price and size. Do you thing the ones on RS look ok for the purpose?

Yeah wil be fine provided the size is correct :slight_smile:

Suppose if you wanna do a mouser order and get the order price up for the free shipping then here are some things I’d pick up

a roll of 63/37 Chipquik solder
If your planning on continuing to work on Switch boards, grab some fuel gauages
some more 8316 IC’s just incase :slight_smile:
your diodes

That should bring your order up to about the limit if you wanna go the Mouser route :slight_smile:

Hi @Severence

Changed the bad diode and now the readings all seem within tolerance with my meter.

Booting into RCM works and can send payload, backlight then comes on but no display on the screen.

I get +5v but only -680ma on the negative line.

Do you think the IC is still not on right, something else to check, or could it be the LCD connector. It looks ok but cant tell for sure.

Thanks

That’s good, likely means the chip hasn’t blown up this time :slight_smile:

Can you clarify, do you mean volts? as if you mean mA and you have your meter in the current/amps mode you’d effectively be shorting it out measuring in this fashion

if you mean volts, disconnect batter/power and make sure the negative rail diode isn’t open again, and if it isn’t make sure it’s on the right way round, after this has been verified, check to see if your getting your 1.8V enable present for the -5V rail (there is two of them)

Sorry, meant -680mv

Getting 1.8v on both the 2 leftmost pads to the IC

on the diode i get .14 one way and 1.5 the other which matches my boards that displays but has a ram issue. Assuming as one side is tied to ground from the coil?

I’d just doubly make sure that diode is on the right way round just incase

That’s good

Seems about right off the top of my head, what’s the resistance to ground on the -5V output in both polarities?

Yes effectively

Can you also let me know the voltage at the cap coming off C2 from my previous image?

pretty sure the diode is on the right way, also checked data sheet before soldering it on to ensure it matches the diode image orientation on the board

Resistance with black on ground = 3kohm / red on ground doesn’t give a proper reading, flashed OL then I just get a moving dot on the screen as if its trying to get the reading but stays like that

Which is cap C2, couldn’t see a previous image?

it’s the one cap in that row of resistors going to pad C2 of the IC (brown)

I’d cross compare this with your other board noting which reading relative to which polarity, I get significantly different readings on my board

C2 = 180kohms on other board, OL on this one
Resistance on other board to -5V black on ground = 36kohm red on ground fluctuates above 100kohms

just checked C2 again under the microscope and it fluctuates between 30k and 80k but cannot settle on a reading

Can you provide the voltage please :slight_smile:

Sorry, anything from 2mv to 300mv fluctuating

Sorry for the delay on this, the datasheet for the IC isn’t clear but it seems to imply the VREF for the neagtive rail is internally generated which would mean provided the -5V output enable is high (1.8V) that 1V should be present at that spot (brown) regardless of what the resistors are doing or what the -5V output is currently at… though I could be wrong, as I say the datasheet isn’t clear on this.

I was under the impression that removing the diode on the -5V rail that one of the many protection modes of the IC would kick in and disable the output for either both or at least the -5V rail and this VREF may still be present, so removed it, but as it turns out thie IC is not quite so robust as I thought and instantly fried it… this explains why your ICs were all dying (because of the open diode all along)

The only case I can think of where my -5V rail was missing was as a result of an intermittent resistor with a bad endcap in that row, I don’t remember but perhaps it was the one connecting to the VREF pin/pad of the IC, I’ll do some more experiments but in the meantime I would check those resistors again and compare to your other board, the other possiblility is that that particular VREF ball is not making proper contact with the board, though I’m not so sure that’s your issue as clearly the IC is at least partially functioning

@Severence no worries, it’s too bloody cold to sit in the shed at night trying to figure this out anyway lol.

I kind of came to the same conclusion as you about VREF as couldn’t see anywhere else it could be coming from although there could be a via under a pad or something.

Does make sense about the diode frying the chips as this one hasn’t gone up in smoke yet so a bit of a good sign so far.

I will try to check the resistors but my multimeter probes are not very fine so do struggle with so many small ones so close to each other. I could try to remove to check but have quite a few of the 0205 ones in the 9th dimension already that it is risky.

The cap doesn’t look good on the side connecting to the IC so may have to replace that. Diagram stakes its 0.1uf, unfortunately my donor is missing the ones above the IC but looking at other posts, it looks as if the ones below the P13 chip are the same so may try to swap one of those out and replace the resistor at the same time for good measure and see what difference it makes.

The datasheet also shows a link between C3 (NON1) and the middle of the 2 resistors coming off VREF but cannot see how that connection is made either. Looks like -5v has a via near the LCD FPC connector but god only knows where that goes. May try tracing it back and make sure I haven’t messed with anything on that side too but as I’m not getting the 1v on VREF, probably not the issue right now.

Appreciate the time you are taking to look into this and try to help me, out of 2 switches I am trying to fix, this one I got with missing components, faulty USB-C and no idea what else is wrong with it and the other one with warped board causing bad ram connections and possibly a bad EMMC it’s certainly not giving me an easy ride for my first go :laughing:

Bit of an update… I swapped the cap on C2 and reflowed the resistors then got OL on C2 so think you may have been right about it not being on properly but the cap also being shot.

Then took the 8316IC off and tried to reball it damaging the ball area exposing traces. Tried on another 8316 I previously tried with incase it was ok and all the readings on the caps and resistors were within tolerance and no longer OL so I thought great. Before powering it though I checked the caps around the rest of the circuit and the 5v in was shorted so that was a no go, must have been fried with the diode issue but at least I got good readings on the others so hopeful a new IC will solve when they arrive in the week.