Nintendo Switch doesn't power on/weird charging

Sorry for the delay.

I can see what appears to be a possible bridge on your USB connector, though again, it could just be the lighting.

Given that you attempted reballing the WIFI IC prior, I would guess the shorts your measuring are as a result of merged balls… though i will double check this for you when i get the chance.

Thanks for trying!
I can confirm that none of the usb pin are connected

yeah my mic kinda sucks.

With the same model of switch I noticed that the same caps are shorted and even removing the wifi chip only one of them (the first one on center left, the one that is not blue/purple)

Wed Feb 10 22-22-27

i’m gonna try to resolder the chip and hope that the cap is still not shorted.
BTW do you know if the switch boot without wifi chip?

Ok soldered back,no short on the cap.
Still no charge.
Measured voltages with battery and usb plugged.
Something is wrong in some points.

Do you know where traces end in those circled points?

How are you reballing the IC/s ?

With the WIFI IC removed you should still see the initial nintendo boot logo (as far as i remember) and Hekate should still work.

I don’t diagnose boards using these voltage charts, they are ultimately useless, sorry

First I remove the exceed tin where the chip is located with copper wire, flux and soldering iron, I clean the remaining Flux with IPA, put again the right quantity of flux and the chip, then I I preheat my heat gun and after 1/2 minute I heat the chip and once is soldered properly I barely touch it with the tweezers.

No boot and not recognized by tegrarcm :frowning:

Sorry, maybe not being clear. How are you putting new balls back on the chip? you can’t just tin it with your iron and place it down, reflow and hope for the best, stencils and paste are required.

If you didn’t use stencils and paste, remove the WIFI IC and flux and wick the pads on the board, if you did the same thing to any of the other IC’s on the board lemme know :slight_smile:

1 Like

OH… That’s embarrassing… I ve always thought this was the good method.
Thanks for avoiding me future problems.

No, luckily this was the only one.
I have the paste but I don’t have stencils, I don’t know a lot about them, do I have to make them(with a 3d printer or something else) or I can find them online? the wifi chip has a very weird pattern, I see if I can find something on the internet and acculturate myself.

Maybe this could help:
https://de.aliexpress.com/item/1005001848426567.html?spm=a2g0o.productlist.0.0.56b31ae6FfNecW&algo_pvid=aac3a3b9-fe73-403d-939d-94a81e0c4ded&algo_expid=aac3a3b9-fe73-403d-939d-94a81e0c4ded-3&btsid=2100bdca16130556501131480e6a4a&ws_ab_test=searchweb0_0,searchweb201602,searchweb201603_

1 Like

Splendid! Thanks.
I have ordered one, now I have to wait a little bit :slight_smile:

You can also get away with using a universal direct heat stencil with correct size/pitch on such a small IC. Make sure you use a name brand solder paste from a legit distributor (mouser etc) my preference is 63/37.

Your LCD connector looks a bit toasty, can you provide larger and clearer images of that area? as i mentioned, you should be seeing the initial boot logo at a minimum without WIFI IC populated… provided your battery is charged

1 Like

Thanks for the advice but it i don’t know how much small they are and i don’t want to risk, it seems too much like a “pro” thing , as you might noticed, i’m still a beginner. :nerd_face:

I already have the MG Chemicals 4900P SAC305. Do you think it’s good enought?

yeah, just on the right, but inside it seems fine to me

Thu Feb 11 23-20-19

Thu Feb 11 23-20-56

Thu Feb 11 23-49-38

Still no screen without the wifi ic . Tried connecting with usb on pc, no signals of recognition from windows. CPU became a little bit warmer once pressed the power button(it’s a signal that it’s powered on? Or could be a cpu short :frowning: ? )
Do you think that bit of toasty on screen connector could be the responsable of the fault?

Good brand but requires reflow temps upward of 230C(unleaded), instead opt for leaded 63/37 (approx 180C) and try getting it in a tub so it’s easier to mix, apply, store and add flux when it inevitably dries out.

Does backlight turn on or blink at black screen?

SoC getting warm indidcates it’s prompted to boot (even in a “braindead” state) so this is normal behaviour. If the SoC isn’t getting warm after plugging in USB (instead of hitting the power button) it indicates the USB isn’t prompting the console to boot and there is an issue with either the USB or related support circuitry. In this case I’d search the forum for “ESD diodes” and test they are good, check your fuse, check you have no bridges between pins on the USB and filters (above P13) in continuity on your meter, idealy you’d check the USBC with a breakout board.

I don’t think it’s the root cause of your faults but it’s possible it’s preventing you from having a display. Scorched plastic turns to carbon, carbon == resistor, carbon going directly across the active latch pins (at the very least) places a “resistor” across all conductors :smiley: this likely isn’t a huge problem in your case but it’s something to watch out for as it can cause more serious problems later down the road in more sever instances :+1:

Also the swelling could also have a negative impact which prevents the conductors from making contact, these connectors have incredibly tight tolerances, to the point where I’ve had situations where a different manufacturers LCD’s on another switch won’t work because the alternative manufacturers ribbon was a fraction thicker, thus “stretching” out the connector/conductors preventing the replacement LCD working.

btw you’ll likely want to go over those pads with wick one more time and flatten them out a tad more prior to reballing and fitting the WIFI IC

Great! thanks!

Nop :frowning:

That’s my case. I’ll search around the forum and check the other things, thanks

Finally some good news.

oh jeez i hope mine isn’t like that

Sure :+1:, it’s just a temporary thing in order to see if it would booted

BTW i’m really thinking buying a thermal camera. it would help me a lot not just for this but even in future. Do you have any suggestions?

Fingers, cheeks and IPA always work well for me, thermal cameras typically just lead to wild goose chases… so deem them a bit of a waste of money… and typically I’m not lucky enough to get the simple dead short cases :frowning:

Okay :joy:. I’ll see if I can find one used and hope for the best. In the next days I’ll check the diodes, bridges and filters. I also have to wait for the USB c breakout board, ordered I think 2 weeks ago from China, hope it will arrive soon.

btw, now you’ve resolved the short in your WIFI area, there doesn’t seem to be any other indications of a dead short elswhere, if anything you have a potential open somewhere (which may have been down to you WIFI IC not making proper contact all along)

So in this instance a thermal camera wouldn’t help at all, and even if you were to have a dead short and thermal camera, you would still require a bench PSU in order to find it.

So just to double check your RCM procedure to boot CFW. Assume this is unpatched? If M92 is removed, plugging in USB won’t start the Switch. You’ll need to short the pins mentioned earlier to cold boot and you’ll need a charged battery connected (if M92 removed). M92 will trigger boot if it simply gets 5v on USB insertion. To force RCM, you need a jig, or easier still, disconnect the EMMC. USB D+/D- lines are all that are required to get Windows to recognise RCM. They lead direct to the SOC via an ESD protection and some filters. Unless your USB-C port is damaged P13, M92, or WiFi should not impact RCM data comms with windows. BQ needed at least to provide VSYS power iirc. This is the most crude of tests, but will confirm if basic systems are working.

If not, can you check USB D+/D- test pads just above USB port. Check resistance to ground. Both should be 4.5MOhm from memory. If not, ESD device can be removed if present as it is optional depending on locale. This can fail when got with excess volts from a damaged USB port. If you still have a bad reading, then you should worry about your SOC…

1 Like

Sorry for late response but i’m moving from a room to another in these days and in the near future, packing lots of stuff and some of my electronic instruments are temporarily unavailable, I managed to find my multimeter. The things i’ve ordered on aliexpress aren’t arrived yet.

I don’t really know how to check esd diodes, checked the one on side A seems fine since i get values greater than 0 in continuity. The other one on side B doesn’t have continuity except for 2 pads which are connected together.
Fuse and filters are good, didn’t notice any bridges.

Still waiting for it , I got the message from aliexpress that it has arrived in my country, hope to see it soon :slight_smile:

Yes :slight_smile:

Didn’t know that. I have tried with a jig and now with this method but still no sign of recognition from windows

D+ 4.6 MOhm and D- 4.65MOhm, at least on the pins of the usbc that are visible and reachable.

However. Good news! I finally got my thermal cam. When i powered on the switch i immediately saw a lot of heat in the max77621(the one in the bottom) area. I sure have to change it. Do you think that it could be the culprit of the problems i have?

Check the diodes in diode mode, you’ll see in Calvin’s post the values within his diagram it should approx read with red probe on ground.

This is one of the reasons i don’t reccommend thermal cameras… your already on to a red herring jumping down a rabbit hole :wink:

I could be wrong but find it unlikely to be the max IC, and i don’t even think you have a short anywhere to begin with

Ensure you have neccessary drivers installed in windows and with EMMC disconnected from mainboard try the USB in another orientation.

1 Like